• No matching documents

    Handset compatibility

    We support a wide variety of handsets and devices. Phones listed as supporting HTTPS provisioning and SRTP will be available on hosted platforms.

    Features mentioned here may also require an appropriate PABX software version, as well as updated handset firmware.

    Models listed here that support HTTPS/SRTP require v.81 Yealink firmware - this is supported in the current release of the PABX software.

    Yealink phones must have shipped originally with v.72 firmware for HTTPS provisioning to work. Even if they have been upgraded since, before this version they shipped with a generic certificate - which means we can't identify them for provisioning.

    Theoretically any handset manufactured since 2015 should have shipped with this.

    ModelLocal auto-provisioningHTTPS auto-provisioningSRTP supportSupported sinceNotes
    CP860YESYESYES Conference phone; HTTPS/SRTP supported since 6.2.17; only supports TLSv1.0
    CP920YESYESYES6.2.17 
    CP960YESYESYES6.2.17 
    T18YESNONO  
    T19YESNONO If HTTPS/SRTP enabled on the system, this phone won't be able to provision
    T19E2YESYESYES  
    T20YESNONO  
    T21YESNONO If HTTPS/SRTP enabled on the system, this phone won't be able to provision
    T21E2YESYESYES  
    T22YESNONO  
    T23YESYESYES  
    T26YESNONO  
    T27YESYESYES  
    T28YESNONO  
    T29YESYESYES  
    T32YESNONO  
    T38YESNONO  
    T40YESYESYES  
    T41PYESYESYES  
    T41SYESYESYES  
    T42GYESYESYES  
    T42SYESYESYES6.2.0Firmware is identical to T41S
    T46GYESYESYES  
    T46SYESYESYES6.2.0Firmware is identical to T41S
    T48GYESYESYES  
    T48SYESYESYES6.2.0Firmware is identical to T41S
    T49YESNONO6.1.0 
    T52YESYESYES6.2.17Requires 6.2.17
    T54YESYESYES6.2.17Requires 6.2.17
    T56YESYESYES6.2.17Requires 6.2.17
    T58AYESYESYES6.2.17Requires 6.2.17
    T58VYESYESYES6.2.17Requires 6.2.17
    VP530YESNONO  
    VP2009YESNONO  
    W52P/W56PYESYESYES DECT phone; firmware is not managed for this model, as we can only update the base station - not the handsets
    W60YESYESYES6.3.0DECT phone; firmware is not managed for this model, as we can only update the base station - not the handsets

    Polycom

    ModelLocal auto-provisioningHTTPS auto-provisioningSRTP supportSupported sinceNotes
    KWS300YESNONO DECT phone
    SoundPoint IP 320YESNONO  
    SoundPoint IP 321YESYESYES  
    SoundPoint IP 330YESNONO  
    SoundPoint IP 331YESYESYES  
    SoundPoint IP 335YESYESYES  
    SoundPoint IP 430YESNONO  
    SoundPoint IP 450YESYESYES  
    SoundPoint IP 500YESNONO  
    SoundPoint IP 501YESNONO  
    SoundPoint IP 550YESYESYES  
    SoundPoint IP 560YESYESYES  
    SoundPoint IP 601YESNONO  
    SoundPoint IP 650YESYESYES  
    SoundPoint IP 670YESYESYES  
    SoundStation DuoYESYESYES6.2.14 
    SoundStation IP 4000YESNONO Conference phone
    SoundStation IP 5000YESYESYES Conference phone
    SoundStation IP 6000YESYESYES Conference phone
    SoundStation IP 7000YESYESYES Conference phone
    VVX 101YESYESYES  
    VVX 201YESYESYES  
    VVX 300YESYESYES  
    VVX 301YESYESYES  
    VVX 310YESYESYES  
    VVX 311YESYESYES  
    VVX 400YESYESYES  
    VVX 401YESYESYES  
    VVX 410YESYESYES  
    VVX 411YESYESYES  
    VVX 500YESYESYES  
    VVX 501YESYESYES  
    VVX 600YESYESYES  
    VVX 601YESYESYES  
    VVX 1500YESYESYES  
    Trio 8500YESYESYES6.3.2Conference phone
    Trio 8800YESYESYES6.3.2Conference phone

    Snom

    ModelLocal auto-provisioningHTTPS auto-provisioningSRTP supportNotes
    190YESNONO 
    300YESNONO 
    320YESNONO 
    360YESNONO 
    370YESNONO 
    710YESYESYESNeeds beta firmware for HTTPS provisioning - download here
    715YESYESYES 
    720YESYESYES 
    725YESYESYES 
    760YESYESYES 
    820YESNONO 
    821YESYESYES 
    870YESYESYES 
    D305YESYESYES 
    D315YESYESYES 
    D345YESYESYES 
    D375YESYESYES 
    D710YESYESYESActually identifies itself as a 710, needs beta firmware for HTTPS provisioning - download here
    D712YESYESYESRequires 6.3.0
    D715YESYESYES 
    D725YESYESYES 
    D745YESYESYES 
    D765YESYESYES 
    M3YESNONO 
    M9YESNONO 
    M9RYESNONO 
    MeetingPoint (MP)YESYESYESConference phone
    PA1YESNONO 

    Gigaset (and ex-Siemens)

    Firmware for Gigaset devices is not managed by the system - they must be updated manually.

    ModelLocal auto-provisioningHTTPS auto-provisioningSRTP support
    A580IPNONONO
    C450IPNONONO
    C460IPNONONO
    N300IPYESNONO
    N510IPYESNONO
    N720IPYESNONO
    N720DMYESNONO< treated as n720
    S450IPNONONO
    S450IPNONONO
    S685IPNONONO

    2N

    We have done interop testing with 2N Helios IP door entry (intercom) devices, but we'd don't autoprovision them. They must be configured manually.

    ModelLocal auto-provisioningHTTPS auto-provisioningSRTP supportNotes
    Helios IP ForceNONOYES - MANUAL PROVISIONING(WITH SOFTWARE LICENCE)SRTP/SIPS requires "Enhanced Security" or "Gold" feature licence, purchased separately
    Helios IP VersoNONOYES - MANUAL PROVISIONING(WITH SOFTWARE LICENCE)We have not tested the device, but deemed it to be compatible. SRTP/SIPS requires "Enhanced Security" or "Gold" feature licence, purchased separately
    Helios IP VarioNONOYES - MANUAL PROVISIONINGWe have not tested the device, but deemed it to be compatible. "Gold" feature licence is included by default
    Helios IP UniNONONO

    We have not tested the device, but deemed it to be compatible. No feature packs are available.

    Cisco (and ex-Linksys)

    Due to licensing restrictions, firmware is not managed for Cisco devices - they must be updated manually.

    Cisco devices typically come in SIP and non-SIP (i.e. Cisco Call Manager) variants. It is critical that any model used supports SIP. (Some models have separate firmware "profiles" that enable this functionality.)

    ModelLocal auto-provisioningHTTPS auto-provisioningSRTP supportNotes
    7941YESNONO 
    7961YESNONO 
    7965YESNONO 
    CP 7811YESYESYESRequires 6.2.11
    CP 7821YESYESYESRequires 6.2.11
    CP 7841YESYESYESRequires 6.2.11
    CP 7861YESYESYESRequires 6.2.11
    PAP2TYESNONOEx-Linksys model
    SPA 112YESNOYES - MANUAL PROVISIONING ONLY 
    SPA 301YESNONO 
    SPA 303YESNONO 
    SPA 502GYESNONO 
    SPA 504GYESNONO 
    SPA 508GYESNONO 
    SPA 509GYESNONO 
    SPA 525GYESNONO 
    SPA 901YESNONOEx-Linksys model
    SPA 921YESNONOEx-Linksys model
    SPA 922YESNONOEx-Linksys model
    SPA 941YESNONOEx-Linksys model
    SPA 942YESNONOEx-Linksys model
    SPA 962YESNONOEx-Linksys model
    SPA 841YESNONOEx-Sipura model
    SPA 1001YESNONOEx-Sipura model
    SPA 2000YESNONOEx-Sipura model
    SPA 2002YESNONOEx-Sipura model
    SPA 2102YESNONOEx-Sipura model
    SPA 8000YESNONOEx-Sipura model

    Panasonic

    All Panasonic phones do not have firmware managed by the PABX for licensing reasons so must have firmware updated manually.

    Currently we only support/auto-provision one model of Panasonic:

    ModelLocal auto-provisioningHTTPS auto-provisioningSRTP supportNotes
    KX-TGP500YESNONODECT phone

    Mitel (formerly Aastra)

    All Mitel (formerly Aastra) phones are legacy support only and should not be recommended for new installs.

    All Mitel (formerly Aastra) phones do not have firmware managed by the PABX for licensing reasons so must have firmware updated manually.

    ModelLocal auto-provisioningHTTPS auto-provisioningSRTP supportNotes
    480iYESNONO 
    6751i (51i)YESNONO 
    6753i (53i)YESNONO 
    6755i (55i)YESNONO 
    6557i (57i)YESNONO 
    6730iYESNONO 
    6731iYESNONO 
    9112iYESNONO 
    9133iYESNONO 

    Other vendors

    Rebadged Snom Phones

    We autoprovision two rebadged models of Snom:

    • Doro ip840 - actually a Snom 360
    • Elmeg IP290 - actually a Snom 190

    Other vendors not listed

    It is quite possible that other phones and devices can work with our system, if they support SIP. They will need to be manually configured on the system (as a generic phone) and on the device itself.